Increased error rates for Lightspeed Payments and Worldpay
Incident Report for Lightspeed - Status Page
Resolved
Our monitoring has confirmed transaction processing have returned to normal and the issue is now resolved.
Posted Apr 01, 2021 - 18:30 EDT
Monitoring
We are seeing an improvement in transaction approvals and the problem is resolving.
Posted Apr 01, 2021 - 18:13 EDT
Identified
We've identified the source of the issue is due to outage with our partner Worldpay, we are currently working with them on the resolution of the issue.
Posted Apr 01, 2021 - 18:01 EDT
Investigating
We are seeing reports of increased error rates for some Lightspeed Payments and Worldpay transactions. We are currently investigating the issue.
Posted Apr 01, 2021 - 17:44 EDT
This incident affected: Lightspeed Payments.