Update Time: Tuesday, August 18 at 15:00 AEST Update Process: Your POS will automatically update after 15:00 AEST.
NEW - You can now move to annual billing yourself from Back Office and pay for the year up front, at a discount on your POS plan. The Change Plan flow shows the discount that applies, the amount due today and your next billing date before you confirm.
IMPROVED - Updated downgrades and switches from annual to monthly billing so they take effect on your next billing date instead of straight away. Your current plan stays active until then, and you can cancel a pending change before it applies. - Updated the country picker in Site Information and Company Settings so Australia and New Zealand appear at the top, with all other countries listed alphabetically below.
RESOLVED - Fixed an issue where the option set update webhook reported the wrong online availability for linked options when an option set was hidden or shown. - Fixed an issue where Pay-at-Table staff reference validation, bill selection or cancellation screens could reappear several times before the transaction completed. - Fixed an issue where AI Menu Import could create an empty option set when an option name matched a product in the same menu. - Fixed an issue where very long product names could overflow the Menu Repricing Tool review table and push pricing columns off screen. - Fixed an issue where the price lists link shown after updating prices could lead to an error page on sites without price lists enabled.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Aug 11, 2026 - 21:29 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).