We are continuing to monitor for any further issues.
Posted Sep 25, 2026 - 10:44 EDT
Monitoring
Service has been fully restored and our Engineering team continues to monitor platform health to immediately respond in the event of any further performance degradation
Posted Sep 25, 2026 - 10:37 EDT
Update
Our Engineering team has identified the issue affecting the NuORDER Brand platform and service is currently being restored. Some users may still be impacted as this process in ongoing.
Posted Sep 25, 2026 - 10:07 EDT
Identified
We are aware of an ongoing issue utilizing NuORDER Brand portals at this time. Our Engineering team is actively working to resolve the problem as quickly as possible. This page will be updated as soon as service is restored, we apologize for the inconvenience.
Posted Sep 25, 2026 - 09:42 EDT
This incident affected: NuORDER (B2B) (The Brand Platform, The Retail / Assortment tool).