Lightspeed Retail (R-Series, S-Series)

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 15:57 EDT

Monitoring

Our upstream networking partner has confirmed a fix for the issues in US East. Our error rates and latency are returning to normal. We continue to monitor the results.
Posted Aug 21, 2025 - 15:43 EDT

Update

We are continuing to investigate ongoing issues. Our upstream networking partner has confirmed issues in the US east region currently, which we suspect is the cause of our elevated error rates and latency for R-series and S-series. We've been informed that a fix is forthcoming.
Posted Aug 21, 2025 - 15:19 EDT

Update

We are continuing to investigate ongoing issues.
Posted Aug 21, 2025 - 15:18 EDT

Investigating

We are currently investigating an elevated number of errors affecting merchants using Lightspeed Retail. A dedicated team is investigating the issue.
Posted Aug 21, 2025 - 14:05 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS, Retail API, Integrated Payments) and Lightspeed Retail (S-Series) (BackOffice).