Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.16.0

Scheduled for Sep 1, 01:00 - 02:00 EDT

Scheduled

Update Time: Tuesday, September 1 at 15:00 AEST
Update Process: Your POS will automatically update after 15:00 AEST.

NEW
Your loyalty customers can now keep their loyalty card in their Apple Wallet or Google Wallet, with their reward progress kept up to date automatically and a lock-screen notification the moment a reward unlocks.

Design the card in your loyalty settings, then let customers join from anywhere using a shareable signup link or a printable QR code, rather than being signed up by staff at the POS. At the till, a one tap scans the pass to attach the customer to the sale.

IMPROVED
- Product variants can now be created and edited through the API.
- Product availability can now be set per site through the API.
- Improved security across Back Office and the POS.
- Improved AI Menu Import so the chat can create a category before you add any products to it.
- Improved card payments by giving cardholders more time to tap, insert or enter a PIN before the POS cancels the sale.
- Updated the API documentation to cover the page-size parameter and the default page length for each endpoint.

RESOLVED
- Fixed an issue where importing a large product catalogue into an account with many sites could run slowly and stall part-way through.
- Fixed an issue where saving a measurement on a product sub-variant returned an error and the change was lost.
- Fixed an issue where duplicating a printer created the copy without its MAC address.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Aug 25, 2026 - 23:22 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).