Lightspeed Retail (X-Series) - Errors when accessing X-Series on Android and iOS
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 21:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2023 - 21:07 EDT
Update
The issue is only impacting retailers when logging in, retailers who are already logged in should be able to continue to trade unaffected.
Posted Apr 25, 2023 - 20:51 EDT
Investigating
We’re investigating an issue preventing some retailers from accessing Lightspeed Retail (X-Series) on Android or iOS devices. We’ll send updates as they arise, thanks for your patience.
Posted Apr 25, 2023 - 20:45 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS for iPadOS).