X-Series - Unable to add Modules on Plus (9.0) Plan and Select Monthly billing

Incident Report for Lightspeed - Status Page

Identified

The problem has been identified.
Posted May 31, 2026 - 09:11 EDT

Investigating

Retailers on Plus 9.0 plan are unable to add modules and select the monthly billing cycle.
Posted May 31, 2026 - 07:57 EDT
This incident affects: Lightspeed Retail (X-Series) (Setup).