Transaction Processing

Incident Report for Lightspeed - Status Page

Resolved

Mastercard has resolved the issue affecting Mastercard payment processing. No further impact has been observed for Lightspeed Payments, and this incident is now closed.
Posted Aug 16, 2026 - 19:07 EDT

Monitoring

Mastercard service is now operational, and we are seeing successful Lightspeed Payments transactions again. We are continuing to monitor payment processing across Wi-Fi and hotspot connections before resolving the incident.
Posted Aug 15, 2026 - 02:29 EDT

Identified

We have identified a widespread issue affecting Mastercard payment processing. Some Lightspeed Payments transactions may be declined, regardless of whether the terminal is connected via Wi-Fi or a hotspot. We’ll provide further updates as they become available.
Posted Aug 15, 2026 - 01:59 EDT

Update

We continue to monitor the Mastercard issue affecting some Lightspeed Payments transactions across Wi-Fi and hotspot connections. Our team is working on this and will provide further updates as more information becomes available.
Posted Aug 15, 2026 - 01:57 EDT

Investigating

We are aware of an issue impacting some customers’ ability to process Lightspeed Payments transactions. Card payments may be declined intermittently across both Wi-Fi and hotspot connections. Our team is investigating and will continue to post updates here as they become available.
Posted Aug 15, 2026 - 01:48 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Lightspeed Payments).