Intermittent issues with closing registers
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 15, 2023 - 19:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2023 - 18:40 EDT
Investigating
We are currently investigating an issue affecting merchants closing their registers, on iOS and web registers.

If you are experiencing this issue, either reload the page (for the web register) or reopen the app (for the iOS app) and try to close the register again.
Posted Apr 15, 2023 - 18:10 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS, Retail POS for iPadOS).