Lightspeed Restaurant - K Series (Issue affecting back office)
Incident Report for Lightspeed - Status Page
Resolved
Access to the Lightspeed Restaurant K Series backoffice has now stabilized and returned to normal
Posted Nov 17, 2020 - 13:17 EST
Investigating
We are currently investigating an issue where the Lightspeed Restaurant K Series backoffice is unavailable. Normal POS functions are unaffected.
Posted Nov 17, 2020 - 12:35 EST
This incident affected: Lightspeed Restaurant.