Degraded performance on EUC1
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jun 07, 2020 - 10:20 EDT
Investigating
We are currently investigating the issue.
Posted Jun 07, 2020 - 10:14 EDT
This incident affected: Lightspeed Restaurant.