We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, July 15 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
IMPROVED - Product pricing loads more quickly when managing large product lists in the Back Office or integrations. - Lightspeed Payments is now more reliable thanks to automatic retries for certain network errors.
RESOLVED - Itemised receipts printed via pay-at-table now display discounts and surcharges correctly at both the item and order level. - Fixed an issue that caused some POS registers to miss updates. Updates now roll out reliably without manual intervention. - Resolved a problem where '%' symbols in product names or descriptions were displayed incorrectly.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jul 08, 2025 - 23:27 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).