Restaurant (O-Series) Back Office Reports delayed for some users

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 04:14 EDT

Monitoring

The fix released earlier today has been refined, we will monitor performance.
Posted Jul 29, 2026 - 02:58 EDT

Identified

Our team are adjusting the work done earlier today to fine tune back office reports performance after users had reported delayed updates. Some users remain impacted by this issue and our team are working to bring this back up to date.
Posted Jul 29, 2026 - 01:33 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Standard Reporting).