Performance Degraded - Lightspeed eCom (Europe)
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 15:00 EDT
Monitoring
We have identified an issue with our eCom Product in the European Region. A dedicated team is researching the issue. We will update you as more information becomes available.
Posted Apr 21, 2020 - 11:42 EDT
This incident affected: Lightspeed eCom (C-Series) (Lightspeed eCom (Europe)).