Financial Services Terminal settings not saving
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 13, 2024 - 08:35 EDT
Investigating
We are currently investigating an issue affecting the L-series back office, specifically related to our Financial Services Terminal settings module
Posted Apr 13, 2024 - 07:23 EDT
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments).