Lightspeed Retail (X-Series) - Unable to load vendhq.com
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 00:48 EDT
Monitoring
We have identified that merchants with an internet service provider that is currently experiencing an outage (e.g. BT and EE) are unable to access vendhq.com.
Posted Oct 31, 2022 - 10:15 EDT
Identified
We have identified that merchants with BT (British Telecom) are currently unable to access vendhq.com due to an outage the ISP is currently experiencing.
Posted Oct 31, 2022 - 10:04 EDT
Investigating
We're investigating an issue where some merchants are unable to access vendhq.com when using certain internet providers. We’ll send updates as they arise, thanks for your patience.
Posted Oct 31, 2022 - 09:49 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).