Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
After monitoring, payment processing has remained stable and the issue is now resolved.
Posted Jul 17, 2021 - 17:40 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2021 - 15:52 EDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2021 - 15:43 EDT
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Payments. A dedicated team is investigating the issue.
Posted Jul 17, 2021 - 15:40 EDT
This incident affected: Lightspeed Retail (Retail Integrated Payments) and Lightspeed Payments.