There may be a short period of delays for data to send across to Bump Screens as the system catches up on order processing.
Please synchronise your POS (Top left corner menu -> Sync) to restore your pricing.
Pricing has been restored from the following timestamp for Wednesday 5th March:
AEST: 4:52AM AEDT: 5:52AM NZST: 7:52AM
Posted Mar 04, 2025 - 20:49 EST
Update
Most customers are able to get back into POS now, some may still be in offline mode.
Note that pricing may still be incorrect for now, we are hoping to have restoration of proper pricing by ~1:30PM AEDT
Posted Mar 04, 2025 - 20:06 EST
Update
We are continuing to work on a fix for this issue.
Posted Mar 04, 2025 - 19:31 EST
Update
We are currently experiencing an outage affecting our O-Series platform.
We are working to resolve this as a top priority, and we are doing everything possible to restore the platform as quickly as possible. In the meantime, here are the immediate next steps you can take to continue operating: