Latency on Sell Screen
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 15:46 EDT
Monitoring
A fix has been implemented and we're monitoring results.

Note: some users may have experienced errored sales during this period. We now encourage users to retry syncing these sales. We strongly advise against using reset data if errored sales remain on the register.
Posted Jul 21, 2023 - 12:58 EDT
Identified
We’ve identified an issue impacting the sell screen and promotions page. Some users might experience delays and timeouts. We’re taking swift action to mitigate this issue and will provide updates as soon as new information becomes available.
Posted Jul 21, 2023 - 11:54 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).