Retail: Smart terminal lost connectivity and appear as offline

Incident Report for Lightspeed - Status Page

Resolved

Transactions are now being processed normally.
Posted Aug 03, 2025 - 13:25 EDT

Update

We are still investigating the issue, which appears to primarily affect merchants in Utah, Colorado, and Idaho. In the meantime, please connect the terminal to a hotspot to allow processing.
Posted Aug 01, 2025 - 14:12 EDT

Investigating

We are still investigating the issue, which seems to affect merchants mainly in Utah, Colorado, and Idaho. In the meantime, please connect the terminal to hotspot mode to allow processing.
Posted Aug 01, 2025 - 13:21 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).