Degraded Lightspeed Payments processing may be experienced on R & S-series

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jul 11, 2026 - 16:39 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2026 - 16:19 EDT

Investigating

Merchants may be experiencing a freeze in their POS while processing but it appears transactions are still successful. A refresh of the POS should resolve the freeze. Please verify Financial Services reporting before retrying transactions.
Posted Jul 11, 2026 - 16:03 EDT
This incident affected: Lightspeed Retail (S-Series) (Payments) and Lightspeed Retail (R-Series) (Integrated Payments).