eCom Cayan Payments
Incident Report for Lightspeed - Status Page
Resolved
The issue has been resolved.
Posted 2 months ago. May 07, 2019 - 11:31 EDT
Investigating
We are investigating a potential issue with eCom NoAm Cayan Payments.
Posted 2 months ago. May 07, 2019 - 11:28 EDT
This incident affected: Lightspeed eCom (Lightspeed eCom (North America & Australia)).