Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 18:22 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2022 - 18:06 EST
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Payments. A dedicated team is investigating the issue.
Posted Nov 17, 2022 - 17:56 EST
This incident affected: Lightspeed Payments.