UK - Hospitality Payments reporting delay
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 07:02 EST
Update
We are continuing to investigate this issue.
Posted Nov 22, 2024 - 04:26 EST
Investigating
We are currently investigating an issue affecting today's payments reporting for a subset of merchants based in the UK.
We appreciate your understanding, and we will keep you updated on any developments.
Posted Nov 22, 2024 - 04:25 EST
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).