App version 6.22 on iPads with a non-English language setting are unable to open registers.

Incident Report for Lightspeed - Status Page

Identified

We've identified the issue preventing registers from opening on app version 6.22 for iPads using a non-English language setting. We're working on a fix and will share updates as they become available.
Posted Aug 07, 2026 - 10:07 EDT

Investigating

We're aware of an issue where retailers using app version 6.22 on iPads with a non-English language setting are unable to open registers. We're actively working on a fix and will provide updates as they become available.
Posted Aug 07, 2026 - 09:59 EDT
This incident affects: Lightspeed Retail (X-Series) (Retail POS for iPadOS).