Parked sales from the Sell Screen are not appearing in the Sales History

Incident Report for Lightspeed - Status Page

Resolved

Issue resolved
Posted Nov 13, 2025 - 21:27 EST

Monitoring

New Parked sales should now show on the Sales history page and are filterable.

For the parked sales made during the impacted period, we are working on a fix. For these sales, please continue to find them in the "Continue" Tab of Sales History
Posted Nov 13, 2025 - 19:40 EST

Investigating

We are currently investigating an issue where parked invoices from the Sell Screen are not appearing in the Sales History.

Workaround: All parked sales are still accessible and can be managed through the "Continue sale" tab.

We will post an update as we investigate.
Posted Nov 13, 2025 - 19:11 EST
This incident affected: Lightspeed Retail (X-Series) (Sales History).