K-Series local payment processing degraded

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved
Posted Sep 25, 2026 - 12:20 EDT

Monitoring

Hospitality K-Series payment processing has recovered after some local devices reported an “Unable to access payment method” error. We are monitoring the service.
Posted Sep 25, 2026 - 11:59 EDT

Update

We are continuing to investigate this issue.
Posted Sep 25, 2026 - 11:46 EDT

Investigating

Hospitality K-Series payment processing experienced degradation, with some local devices reporting an “Unable to access payment method” error.
Posted Sep 25, 2026 - 11:45 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).