Lightspeed Retail Payment Processing Errors

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 18:35 EDT

Monitoring

Our team has identified and resolved an issue with Lightspeed Retail payments that may have cause intermittent errors when processing payments. We are now monitoring to ensure payments are fully operational.
Posted Mar 13, 2026 - 15:26 EDT
This incident affected: Lightspeed Retail (S-Series) (Payments), Lightspeed Retail (R-Series) (Integrated Payments), and Lightspeed Retail (X-Series) (Payments).