Lightspeed Retail (X-Series) - Experiencing connection issues when attempting to sync data from Lightspeed to Xero
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Sep 08, 2022 - 00:07 EDT
Monitoring
We are seeing less errors from our end. We will continue to monitor.
Posted Sep 07, 2022 - 21:25 EDT
Investigating
We are currently investigating this and we are also getting in touch with the third party involved.
Posted Sep 07, 2022 - 19:00 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS for iPadOS, Payments).