Settlement delay Canada
Incident Report for Lightspeed - Status Page
Resolved
We have resolved the payout issue with our banking partners that impacted a subset of Canadian merchants.
All missing sales were included in today's settlement and should be expected to be received by the end of the business day.
Thank you for your patience as we worked to resolve this issue
Posted Aug 13, 2024 - 15:39 EDT
Investigating
We're currently investigating an issue where a subset of merchants based in Canada are experiencing payout delays.
We understand how important it is to have access to your funds, and our team is keeping in touch with our banking partners as they work on a fix. Thank you for your patience with us as we work to resolve this issue
Posted Aug 13, 2024 - 13:05 EDT
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).