Lightspeed Retail (X-Series) - Error on some integrated payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Dec 05, 2022 - 16:53 EST
Monitoring
We are monitoring the situation as the issue on a downstream provider looks to be resolved
Posted Dec 05, 2022 - 16:17 EST
Investigating
Some users are reporting an inability to process credit card payments or reach certain pages in their Backoffice. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted Dec 05, 2022 - 15:58 EST
This incident affected: Lightspeed Retail (X-Series) (Payments).