Lightspeed Retail Merchants are experiencing slowness when finalizing a sale
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 13:09 EST
Monitoring
Performance is returning to normal. We will continue to monitor the situation.
Posted Dec 07, 2021 - 12:47 EST
Identified
We have identified the issue with our underlying service providers who are working to resolve the issue as soon as possible. Transactions may still complete but could take longer than usual to process.
Posted Dec 07, 2021 - 12:35 EST
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 12:20 EST
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Retail. A dedicated team is investigating the issue.
Posted Dec 07, 2021 - 12:08 EST
This incident affected: Lightspeed Retail (Retail POS, Retail Integrated Payments).