K-series: Legacy Split payment issue with app version 26.22 only

Incident Report for Lightspeed - Status Page

Resolved

The issue affecting legacy split payments on app version 26.22 has been successfully resolved.

A hotfix has been deployed to the App Store to address the race condition that caused affected transactions to close out without payment confirmation.

If you are currently experiencing this issue, please update your app immediately to the latest version: 26.22.1.

How to update: Open the App Store on your device, search for the Lightspeed Hospitality app, and tap Update.
Posted Jun 04, 2026 - 03:57 EDT

Identified

App Version 26.22 only: Orders using legacy split payments with a native payment integration close out without receiving a payment confirmation. We have identified the issue and implemented a fix. We are currently waiting for the updated app version to become available on the App Store. A workaround would be to turn on advanced bill splitting.

https://k-series-support.lightspeedhq.com/hc/en-us/articles/360051089493-Check-splitting
Posted Jun 03, 2026 - 12:20 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Payments).