Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 09, 2025 - 23:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 02, 2025 - 23:25 EST
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Monday, March 10 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
RESOLVED - Fixed gift card top-up errors not displaying correctly on POS. - Fixed promos with a 'Minimum Purchase Required' of 0 creating 0x item charges on POS. - Fixed an issue where selecting 'Complete Money Out' multiple times in quick succession created duplicate records. - On-Account Sales now include tip amounts in Account Statements. - Bulk payments can now be applied to On-Account sales when 'Require Customer' is enabled and for $0 sales.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Mar 02, 2025 - 23:24 EST
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).