Performance Degraded - Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted 13 days ago. Jun 02, 2019 - 19:04 EDT
Monitoring
Services are gradually coming back. Our engineering team are monitoring the situation. Thank you for your patience.
Posted 13 days ago. Jun 02, 2019 - 18:41 EDT
Investigating
We have identified an issue with Lightspeed Retail. A dedicated team is researching the issue. We will update you as more information becomes available.
Posted 13 days ago. Jun 02, 2019 - 17:08 EDT
This incident affected: Lightspeed Retail (Retail POS) and Lightspeed Payments.