Lightspeed Analytics
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 11:25 EDT
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Analytics. A dedicated team is investigating the issue.
Posted Aug 17, 2020 - 11:10 EDT
This incident affected: Lightspeed Retail (Lightspeed Analytics).