Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.6.0

Scheduled for Apr 14, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Tuesday, April 14 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

NEW
- The Customers API now supports a mobile field for creating, reading, updating, and searching customers.

IMPROVED
- The Back Office Loyalty dashboard now displays Average Order Value (AOV) and Non-loyalty AOV metrics.
- The Online Products tab in Back Office is now visible for all merchants, regardless of enabled integrations.

RESOLVED
- Production dockets now sort option sets correctly in all conditions.
- Receipts reprinted from sale history now display the correct Sale ID.
- The "Chat to Support" button on the password reset page no longer shows an error.
- The Loyalty date filter now displays correctly on iPads in portrait mode.
- The POS auto log-out timer no longer fires during active gift card transactions.
- Gift card numbers with leading or trailing spaces are now handled correctly, preventing unexpected transaction failures.
- Online order prep time overrides in POS now apply correctly when set to 0 minutes.
- Bulk-applying a payment to a customer account no longer creates $0.00 tender entries against orders that did not receive any of the payment.
- Group orders with $0 items no longer prematurely replace the Checkout button with "Finish & Print".


IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Apr 08, 2026 - 22:53 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).