C-Series Backoffice Empty Pages.

Incident Report for Lightspeed - Status Page

Update

We are monitoring the back office search issues: All back-office data is visible. No data was lost, and storefronts remain unaffected. We are working to fix the search functionality in the bottom-left menu. All other search functionalities are fully resolved for NOAM. For EMEA, data is being served via a fallback search; while all records are accessible, merchants may experience limited search (and filter) functionality or slower results until fully resolved.
Posted Mar 16, 2026 - 05:54 EDT

Monitoring

the data is now back in the back office for both NOAM and EU.
Posted Mar 14, 2026 - 14:07 EDT

Investigating

"We are currently investigating this issue."
Posted Mar 14, 2026 - 14:05 EDT
This incident affects: Lightspeed eCom (C-Series) (Lightspeed eCom (Europe), Lightspeed eCom (North America & Australia)).