Chronogolf by Lightspeed
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 09:40 EDT
Identified
Chronogolf is currently experiencing technical difficulties affecting the teesheet mark-as-paid after sending a reservation to POS. We are looking into this and will provide updates as soon as possible.
Posted Apr 28, 2020 - 09:34 EDT
This incident affected: Chronogolf by Lightspeed (Tee Sheets).