US Payout delays
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 09:24 EDT
Monitoring
Our engineering team has confirmed that all transfers have been successfully sent to affected merchants. We understand how important it is to access your funds when expected, and our team is actively working on preventing similar disruptions from happening in the future. Thank you for your patience as we worked to resolve this disruption.
Posted May 29, 2024 - 12:58 EDT
Identified
Due to an issue outside our payments platform which has now been resolved, US payouts scheduled for May 28, 2024 will be delayed by 1 business day
Posted May 28, 2024 - 08:28 EDT
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).