Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 15:37 EDT
Monitoring
The problem with American Express transaction processing was resolved. Transaction processing returned to normal.
Posted Oct 21, 2021 - 15:29 EDT
Investigating
We are experiencing a degraded service for AmericanExpress credit cards in NoAm affecting merchants using Lightspeed Payments. We are investigating the issue with our partners.
Posted Oct 21, 2021 - 15:05 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).