Unable to edit some products
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Jan 05, 2025 - 15:06 EST
Investigating
Some merchants are reporting an inability to edit certain products. We are investigating the issue and its potential cause(s). Please subscribe to updates on this page for new information as we uncover it.
Posted Dec 29, 2024 - 16:01 EST
This incident affected: Lightspeed Retail (X-Series) (Products).