Merchants experiencing issues to sign in
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 13, 2023 - 22:35 EDT
Monitoring
The sign in issue reported by a few merchants is caused by their Internet provider. All our systems are operational. Updating the DNS settings seems to solve the issue.
Posted Apr 13, 2023 - 21:05 EDT
Identified
It appears the issue is with some Internet providers. Updating the DNS settings seems to have solved the issue for some merchants.
Posted Apr 13, 2023 - 18:52 EDT
Investigating
We are currently investigating an issue in which some merchants are unable to sign in.
Posted Apr 13, 2023 - 18:28 EDT
This incident affected: Lightspeed Retail (X-Series) (Retail POS).