Delays - Entities Results Outdated / Lagging

Incident Report for Lightspeed - Status Page

Monitoring

We have identified the root cause and now we are working on the recovering.
We will post an update once the delay is over.
Thank you for your patience.
Posted Aug 05, 2026 - 23:39 EDT

Identified

We’re looking into an issue where Entities (products, sales and inventory and customers) are displaying out-of-date results to Lightspeed (X-Series) retailers and will keep you posted with updates as they come. Thanks for your patience.
Posted Aug 05, 2026 - 22:45 EDT
This incident affects: Lightspeed Retail (X-Series) (Customer Management, Inventory, Products).