Payment Terminal Processing Disruption

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 21:05 EDT

Investigating

We are aware of an issue affecting certain payment terminal integrations. Our team is actively investigating and working to restore normal processing. We apologise for the disruption to your sales operations and will provide updates as we learn more.
Posted Jul 09, 2026 - 19:14 EDT
This incident affected: Lightspeed Retail (X-Series) (Payments).