Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 19, 2026 - 20:30 EDT
Scheduled
Update Time: Wednesday, May 20 at 10:30 AEST
During this maintenance window Insights Payments reports will be temporarily unresponsive, and Insights data may take a short time to catch up once the release is complete
NEW - Added a Lightspeed Payments payment mode dimension to the Payments view for Insights Custom so reports can distinguish between card payments, Tap to Pay, MOTO and Pay at Table.
RESOLVED - Fixed an issue in Custom Insights where measures in the Reconciliation view, including total tips received, were inflated when joined to other views in a report. - Fixed an issue in the Custom Insights Purchase explore where deleted purchases still appeared in reports
Posted May 19, 2026 - 18:10 EDT
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (Insights).