We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Monday, June 22 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
NEW - Give Feedback is now available throughout the Back Office. Share product feedback through an AI-assisted conversation that captures the right context and sends it straight to our Product team. - The Core API now lets integrations retrieve all of a site's option sets in a single request.
IMPROVED - Improved Split by Product at checkout so quantity-modified line items can now be split unit by unit.
RESOLVED - Fixed an issue where the Refund Sale button was intermittently hidden in POS Sale History, preventing a refundable sale from being refunded. - Fixed an issue where the order-completed webhook reported a Pay-at-Table order's course status as "pending" instead of "called", which could stop kitchen display and order-management partners closing out completed orders. - Fixed an issue where tapping Email or Print receipt before an On Account order finished syncing could silently fail to send the receipt. - Fixed an issue where Kiosk plan names displayed incorrectly on invoices and in the Back Office subscriptions list.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jun 17, 2026 - 00:51 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).