Performance Issue - Lightspeed Retail
Incident Report for Lightspeed - Status Page
Resolved
Users are reporting that they are able to log in to Lightspeed Retail and all systems look stable. We are considering this issue as resolved. Our engineers will continue to monitor the situation.
Posted 9 days ago. Sep 10, 2019 - 11:07 EDT
Investigating
We have gotten reports of slowness and some users unable to log in to the Lightspeed Retail product. Our engineers are investigating the issue.
Posted 9 days ago. Sep 10, 2019 - 10:37 EDT
This incident affected: Lightspeed Retail (Retail POS).