Payments not reaching terminals in some cases
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Feb 15, 2020 - 15:39 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2020 - 14:39 EST
Investigating
We have identified an issue with payments reaching terminals. A dedicated team is working on the issue.
Posted Feb 15, 2020 - 14:25 EST
This incident affected: Lightspeed Retail (Retail POS) and Lightspeed Payments.