Lightspeed Restaurant L Series - Issue processing credit card payments
Incident Report for Lightspeed - Status Page
Resolved
After monitoring, we have confirmed this issue is now resolved and credit card processing has returned to normal
Posted Aug 22, 2021 - 00:05 EDT
Monitoring
We are currently monitoring an issue where merchants using TSYS Sierra and Lightspeed Payments were unable to process credit card transactions. Transaction processing is returning back to normal and we are monitoring accordingly
Posted Aug 21, 2021 - 23:48 EDT
This incident affected: Lightspeed Restaurant and Lightspeed Payments.